Error while publishing an InfoPath 2010 form to SharePoint: “The following URL is not valid”

Today I got this error:

image

I tried to deploy a simple form to the SharePoint location http://sharepoint.local. – This location is a root site collection!!!

I got the error:

The following URL is not valid: “http://sharepoint.local”

I swear: It is valid!!! Smiley

 

The URL uses a host header name. Specifying the Central Administration URL (using the machines name) did work at the same time.

Than I activated the network adapter of the virtual machine to have Google available in the machine to research into the problem. – In this moment the problem was gone! – I turned off the network adapter and the problem was back. – OK. That’s it. – Deactivating the “System Event Notification Service” (net stop sens at command line) solved the problem. But you should restart the service as soon as possible!

2 thoughts on “Error while publishing an InfoPath 2010 form to SharePoint: “The following URL is not valid”

  1. 1. You should be publishing it to some document library. So give that document library name in the URL.
    2. Give the IP to machine name resolution in to your host file.
    3. Try to give IP of the machine with the port instead of using name.

    1. hi!

      thanks for your comment. The domain name is already registered in the HOSTS file. I’ve also installed the MS Loopback Network adapter. that does not help. I cannot store the InfoPath form in a document library because it have to be a Administrator Approved Form.

      Ingo

Leave a Reply

Your email address will not be published. Required fields are marked *